Page MenuHomeVyOS Platform

canoziia (canoziia)
User

Projects

User does not belong to any projects.

User Details

User Since
Apr 24 2024, 7:10 AM (126 w, 3 d)

Recent Activity

Aug 25 2026

canoziia added a comment to T9127: Bug: Slow-initializing NIC (Intel ice / empty E823-L SFP cages) loses VyOS interface-naming race → interface reordering, duplicate MAC via hw-id, and total management lockout on reboot.

If you need to temporarily resolve this issue, you can try increasing the number of all ethX (for example, starting the interface naming from eth100). I have a server with 8x E823-L ports and named them from eth101-eth108.

Aug 25 2026, 4:02 PM · VyOS Rolling
canoziia added a comment to T9243: VPP VLAN interface keeps A/D when it's not disabled.

https://github.com/vyos/vyos-vpp-patches/pull/55

Aug 25 2026, 3:24 PM · VyOS Rolling
canoziia added a comment to T9243: VPP VLAN interface keeps A/D when it's not disabled.

If you don't mind I can post a report from LLM. Although it's long, I think it did find the problem.

Aug 25 2026, 12:59 PM · VyOS Rolling
canoziia added a comment to T9243: VPP VLAN interface keeps A/D when it's not disabled.

Hello, I finally use 2 patches to solve this:

diff --git a/src/plugins/linux-cp/lcp_interface_sync.c b/src/plugins/linux-cp/lcp_interface_sync.c
index ca7638e..61db256 100644
--- a/src/plugins/linux-cp/lcp_interface_sync.c
+++ b/src/plugins/linux-cp/lcp_interface_sync.c
@@ -363,7 +363,7 @@ lcp_itf_interface_add_del (vnet_main_t *vnm, u32 sw_if_index, u32 is_create)
   const vnet_sw_interface_t *sw;
   uword is_sub;
Aug 25 2026, 12:37 PM · VyOS Rolling

Aug 24 2026

canoziia created T9243: VPP VLAN interface keeps A/D when it's not disabled.
Aug 24 2026, 9:20 AM · VyOS Rolling
canoziia added a comment to T9063: VPP commit fails at lcp_nl_resync() on kernel 6.18.

Hello, I found this is because the lcp_nl_resync operation is a potentially long-running full netlink synchronization, but the VyOS wrapper invokes it with the generic VPP PAPI response timeout of 5 seconds.

Aug 24 2026, 8:45 AM · VyOS Rolling

Jul 7 2026

canoziia added a comment to T9065: VPP sflow not work when enable-egress is disabled.

sorry, With VPP sFlow enabled but without set system sflow enable-egress, the generated hsflowd config will not contain psample { group=1 }. I cannot edit this task. I think I choose the wrong form type (I should create bug report, not task)

Jul 7 2026, 6:48 PM · VyOS Rolling
canoziia created T9065: VPP sflow not work when enable-egress is disabled.
Jul 7 2026, 5:37 PM · VyOS Rolling
canoziia created T9063: VPP commit fails at lcp_nl_resync() on kernel 6.18.
Jul 7 2026, 5:20 PM · VyOS Rolling

Apr 9 2026

canoziia updated the task description for T8468: MAC address modifying on a VPP interface does not take effect.
Apr 9 2026, 6:48 AM · VyOS Rolling
canoziia created T8468: MAC address modifying on a VPP interface does not take effect.
Apr 9 2026, 6:48 AM · VyOS Rolling

Nov 10 2025

canoziia created T8000: op-mode: "run generate pki wireguard key-pair install" returns error.
Nov 10 2025, 4:41 AM · VyOS 1.5 Circinus (2026.02), VyOS Rolling

Oct 1 2025

canoziia added a comment to T6293: add Mediatek MT7921 to defconfig.

I just built a new image with the driver enabled, and it no longer causes kernel panic on my setup.

Oct 1 2025, 9:40 AM · VyOS 1.4 Sagitta (1.4.0-GA), VyOS 1.5 Circinus

Sep 22 2025

canoziia added a comment to T7823: DHCP-server lease cannot be cleared.

PR: https://github.com/vyos/vyos-1x/pull/4741

Sep 22 2025, 2:56 PM · VyOS 1.5 Circinus (1.5-stream-2025-Q3), VyOS Rolling
canoziia added a comment to T7823: DHCP-server lease cannot be cleared.

The problem is caused by inconsistent parameter ordering: in def kea_delete_lease(inet, ip_address, vrf_name=''): permalink the vrf_name is placed after ip_address, while in if not kea_delete_lease(inet, vrf, address): permalink the vrf appears before the address.

Sep 22 2025, 2:28 PM · VyOS 1.5 Circinus (1.5-stream-2025-Q3), VyOS Rolling

Sep 18 2025

canoziia added a comment to T7818: 'add system image' error if we choose not to copy an active config.

If one chooses not to copy config to new image, according to https://github.com/vyos/vyos-1x/blob/f46bd3ae7d225d67968397cf85887ae64160592a/src/op_mode/image_installer.py#L1105-L1108 , it won't copy default config to f'{target_config_dir}/config.boot' (This behavior is different from install_image, in which it copied the default config to f'{target_config_dir}/config.boot'). So get_cli_kernel_options cannot find the file and raise an error.

Sep 18 2025, 6:29 PM · VyOS 1.4 Sagitta (1.4.4), VyOS 1.5 Circinus (2025.11)
canoziia added a comment to T7497: BGP route-reflector-client - 'peer_group_as' bug.

We can close it because it's similar to https://vyos.dev/T7708 and has now been fixed.

Sep 18 2025, 5:53 AM

Aug 28 2025

canoziia committed rVYOSONEX1c8e789b6cd2: bgp: T7708: correct logic for route-reflector-client peer_as check.
Aug 28 2025, 2:17 PM

Aug 15 2025

canoziia added a comment to T7708: BGP config fails when route-reflector-client is configured and peer-group is not used.

This appears to be a logical bug. I have opened a Pull Request to fix it.
https://github.com/vyos/vyos-1x/pull/4663

Aug 15 2025, 12:06 PM · VyOS 1.4 Sagitta (1.4.4), VyOS 1.5 Circinus (2025.11)

Apr 27 2025

canoziia added a comment to T7220: Add the option to disable enforce-first-as at peer level.

Should I close this task?

Apr 27 2025, 4:34 AM · VyOS 1.5 Circinus (2026.02), VyOS Rolling
canoziia added a comment to T7394: Image upgrade fails when the "system option kernel" subtree is empty .

Still happening somewhere

{F14387702}

Apr 27 2025, 4:27 AM · VyOS 1.5 Circinus (1.5-stream-2025-Q2), VyOS 1.4 Sagitta (1.4.3), VyOS Rolling

Apr 25 2025

canoziia committed rVYOSONEX1deea4067298: image_installer: T7394: add system image raise "Error: argument of type….
Apr 25 2025, 7:48 PM
canoziia changed Is it a breaking change? from none to compatible on T7394: Image upgrade fails when the "system option kernel" subtree is empty .
Apr 25 2025, 3:35 AM · VyOS 1.5 Circinus (1.5-stream-2025-Q2), VyOS 1.4 Sagitta (1.4.3), VyOS Rolling
canoziia created T7394: Image upgrade fails when the "system option kernel" subtree is empty .
Apr 25 2025, 3:33 AM · VyOS 1.5 Circinus (1.5-stream-2025-Q2), VyOS 1.4 Sagitta (1.4.3), VyOS Rolling

Apr 24 2025

canoziia committed rVYOSONEXb2972262e112: T7220: Add the option to disable enforce-first-as at peer level.
Apr 24 2025, 3:25 PM

Apr 25 2024

canoziia added a comment to T6258: Add IPv6 base-reachable-time option to interfaces.

This sysctl option is deprecated

DEPRECATED PARAMETERS         top

       The base_reachable_time and retrans_time are deprecated.  The
       sysctl command does not allow changing values of these
       parameters.  Users who insist to use deprecated kernel interfaces
       should push values to /proc file system by other means.  For
       example:

       echo 256 > /proc/sys/net/ipv6/neigh/eth0/base_reachable_time

I propose to add new option under interface

set interfaces ethernet eth1 ip[v6] base-reachable-time xxx
Apr 25 2024, 7:09 AM · VyOS 1.4 Sagitta (1.4.0-epa3)
canoziia added a comment to T6258: Add IPv6 base-reachable-time option to interfaces.

Hi everyone, I think I found the simplest configuration that can reproduce this problem. If we set up firewall and use this command(set system sysctl parameter net.ipv6.neigh.eth3/2) in configuration at the same time, an error message will show when startup.
This is an example

set firewall
set interfaces ethernet eth0 address 'xxx.xxx.184.32/24'
set interfaces ethernet eth0 hw-id 'xx:xx:xx:xx:xx:50'
set interfaces ethernet eth1 hw-id 'xx:xx:xx:xx:xx:ba'
set interfaces ethernet eth1 vif 2
set interfaces loopback lo
set protocols static route xxx.xxx.0.0/0 next-hop xxx.xxx.184.1
set service ntp allow-client xxxxxx 'xxx.xxx.0.0/0'
set service ntp allow-client xxxxxx '::/0'
set service ntp server xxxxx.tld
set service ntp server xxxxx.tld
set service ntp server xxxxx.tld
set service ssh
set system config-management commit-revisions '100'
set system conntrack modules ftp
set system conntrack modules h323
set system conntrack modules nfs
set system conntrack modules pptp
set system conntrack modules sip
set system conntrack modules sqlnet
set system conntrack modules tftp
set system console device ttyS0 speed '115200'
set system host-name xxxxxx
set system login user xxxxxx authentication encrypted-password xxxxxx
set system sysctl parameter net.ipv6.neigh.eth1/2.base_reachable_time_ms value '14400000'
set system syslog global facility all level 'info'
set system syslog global facility local7 level 'debug'

If delete the first line (set firewall), system will start normally without error message.

Apr 25 2024, 3:46 AM · VyOS 1.4 Sagitta (1.4.0-epa3)