Page MenuHomeVyOS Platform

OSPF: interface config is not removed
Closed, ResolvedPublic

Description

When interfaces are configured for OSPF and there is a current running FRR configuration that looks like this:

!
interface eth0.201
 ip ospf authentication message-digest
 ip ospf message-digest-key 10 md5 ospfmybllnet
!
interface eth1
 ip ospf bfd
 ip ospf mtu-ignore
 ip ospf transmit-delay 5
!
router ospf
 ospf router-id 172.18.254.201
 log-adjacency-changes detail
 auto-cost reference-bandwidth 100
 timers throttle spf 200 1000 10000
 passive-interface default
 no passive-interface eth0.201
 network 172.18.201.0/24 area 0
 network 172.18.254.201/32 area 0
!

Applying the new FRR configuration of:

!
interface eth0.201
 ip ospf authentication message-digest
 ip ospf message-digest-key 10 md5 ospfmybllnet
 ip ospf hello-interval 10
 ip ospf retransmit-interval 5
 ip ospf transmit-delay 1
 ip ospf dead-interval 40
!
router ospf
 network 172.18.201.0/24 area 0
 network 172.18.254.201/32 area 0
 auto-cost reference-bandwidth 100
 log-adjacency-changes detail
 ospf abr-type cisco
 ospf router-id 172.18.254.201
 passive-interface default
 no passive-interface eth0.201
 timers throttle spf 200 1000 10000
!

Will not remove the OSPF interface configuration of eth1 - it continues to stay.

Details

Difficulty level
Unknown (require assessment)
Version
1.4-rolling-202101291609
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)

Event Timeline

c-po triaged this task as Normal priority.Jan 29 2021, 4:17 PM
c-po created this task.
c-po created this object in space S1 VyOS Public.
c-po added a project: VyOS 1.4 Sagitta.

Is this probably also an issue for IS-IS?

c-po claimed this task.
c-po raised the priority of this task from Normal to High.