Page MenuHomeVyOS Platform

BGP exchanges prefixes without specified address-family
Closed, ResolvedPublicBUG

Description

I do not know if this is as intended or a bug.

While playing with a local BGP setup I encountered the following symptome:

R1 AS65000

vyos@vyos# show interfaces ethernet eth0 vif 666
 address 2001:db8:1::1/64
vyos@vyos# show protocols bgp
 bgp 65000 {
     address-family {
         ipv4-unicast {
             network 10.0.0.0/9 {
             }
             network 10.128.0.0/9 {
             }
         }
     }
     neighbor 2001:db8:1::2 {
         remote-as 65001
     }
     parameters {
         log-neighbor-changes
         router-id 172.18.254.202
     }
 }
vyos@vyos# show protocols static route
 route 10.0.0.0/9 {
     blackhole {
     }
 }
 route 10.128.0.0/9 {
     blackhole {
     }
 }
vyos@vyos# vtysh -c "show run"
Building configuration...

Current configuration:
!
frr version 7.0.1-20190514-01-gcd305c0
frr defaults traditional
hostname LR2.wueIII.mybll.net
log syslog informational
agentx
service integrated-vtysh-config
!
ip route 10.0.0.0/9 Null0
ip route 10.128.0.0/9 Null0
!
interface bond0
 description ddd
!
router bgp 65000
 bgp router-id 172.18.254.202
 bgp log-neighbor-changes
 neighbor 2001:db8:1::2 remote-as 65001
 !
 address-family ipv4 unicast
  network 10.0.0.0/9
  network 10.128.0.0/9
 exit-address-family
!
line vty
!
end

R2 AS65001

vyos@vyos# show interfaces ethernet eth0 vif 666
 address 2001:db8:1::2/64
vyos@vyos# show protocols bgp
 bgp 65001 {
     address-family {
         ipv4-unicast {
             network 192.168.0.0/16 {
             }
         }
         ipv6-unicast {
             network 2001:db9::/32 {
             }
         }
     }
     neighbor 2001:db8:1::1 {
         remote-as 65000
     }
     parameters {
         log-neighbor-changes
         router-id 172.18.254.203
     }
 }
vyos@vyos# show protocols static
 route 192.168.0.0/16 {
     blackhole {
     }
 }
 route6 2001:db9::/32 {
     blackhole {
     }
 }
vyos@vyos#  vtysh -c "show run"
Building configuration...

Current configuration:
!
frr version 7.0.1-20190514-01-gcd305c0
frr defaults traditional
hostname LR3.wueIII.mybll.net
log syslog informational
agentx
service integrated-vtysh-config
!
ip route 192.168.0.0/16 Null0
ipv6 route 2001:db9::/32 Null0
!
router bgp 65001
 bgp router-id 172.18.254.203
 bgp log-neighbor-changes
 neighbor 2001:db8:1::1 remote-as 65000
 !
 address-family ipv4 unicast
  network 192.168.0.0/16
 exit-address-family
 !
 address-family ipv6 unicast
  network 2001:db9::/32
 exit-address-family
!
line vty
!
end

Details

Difficulty level
Unknown (require assessment)
Version
1.2.2
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Unspecified (possibly destroys the router)
Issue type
Bug (incorrect behavior)

Event Timeline

c-po updated the task description. (Show Details)
syncer changed the task status from Open to Needs testing.Nov 16 2019, 11:43 PM
syncer assigned this task to Viacheslav.
syncer triaged this task as Low priority.
syncer edited projects, added VyOS 1.3 Equuleus; removed VyOS 1.2 Crux.

By default, FRR uses all neighbors in afi ipv4.
This behavior can be disabled with:

set protocols bgp x.x.x.x parameters default no-ipv4-unicast

In that case, you should to declare a proper afi for each neighbor.

@c-po Can we close this or do you have another ideas?

erkin renamed this task from BGP exchanges prefixes withou specified address-family to BGP exchanges prefixes without specified address-family.Aug 31 2021, 6:52 PM
erkin set Issue type to Bug (incorrect behavior).