[ service dhcp-server ] Unexpected error with Kea configuration: one of the supported identifiers must be specified for host reservation: circuit-id, client- id, duid, flex-id, hw-address (/run/kea/kea-dhcp4.conf:69:21) (/run/kea/kea-dhcp4.conf:41:5) [[service dhcp-server]] failed [ system option ] WARNING: Kernel configuration options have changed. To apply these changes, you must save the configuration and reboot the system! Commit failed [edit]
The previous VyOS 1.4 configuration used:
set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 default-router '10.2.1.1' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 lease '604800' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 name-server '10.2.1.3' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 range 0 start '10.2.1.11' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 range 0 stop '10.2.1.249' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 011_UBB1 ip-address '10.2.1.11' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 011_UBB1 mac-address '00:50:00:33:d5:b7' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 012_UBB2 ip-address '10.2.1.12' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 012_UBB2 mac-address '00:50:00:33:d5:66' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 087_SW807 ip-address '10.2.1.87' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 087_SW807 mac-address '00:50:00:38:9a:fe' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 088_SW808 set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 089_SW809 set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 101_AP101 mac-address '00:50:00:34:31:d6' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 102_AP102 ip-address '10.2.1.102' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 102_AP102 mac-address 'd8:b3:70:31:c6:3f' set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 106_AP106
The issue happens when there is an empty node like set service dhcp-server shared-network-name LAN subnet 10.2.1.0/24 static-mapping 088_SW808 with no configuration below.