When a key-name to a non-existing tsig-key is specified in the path
service dhcp-server-dynamic-dns-update forward-domain example.net key-name
isc-kea-dhcp-ddns-server.service fails to start due to this error (whereby vyos-ddns is the specified non-existing tsig-key):
Apr 16 20:01:25 vyos kea-dhcp-ddns[33443]: ERROR DHCP_DDNS_CONFIG_FAIL DHCP-DDNS server configuration failed: DdnsDomain : specifies an undefined key: vyos-ddns (/var/ru> Apr 16 20:01:25 vyos kea-dhcp-ddns[33443]: 2026-04-16 20:01:25.315 FATAL [kea-dhcp-ddns.dctl/33443.140668355493440] DCTL_CONFIG_FILE_LOAD_FAIL DhcpDdns reason: DdnsDomain : sp> Apr 16 20:01:25 vyos kea-dhcp-ddns[33443]: Service failed: Could Not load configuration file: DdnsDomain : specifies an undefined key: vyos-ddns (/var/run/kea/kea-dhcp-d> Apr 16 20:01:25 vyos systemd[1]: isc-kea-dhcp-ddns-server.service: Main process exited, code=exited, status=1/FAILURE
When setting a key-name it should be checked that a matching key exists within
service dhcp-server dynamic-dns-update tsig-key