Page MenuHomeVyOS Platform

GeoIP fail to update due to incorrect cron parameter --force
Closed, ResolvedPublicBUG

Description

VyOS 1.5.0 has the following in /etc/cron.d/vyos-geoip

user@router:/etc/cron.d$ cat vyos-geoip
30 4 * * 1 root sg vyattacfg "/usr/libexec/vyos/geoip-update.py --force" >/tmp/geoip-update.log 2>&1

However it appears the 1.5.0 geoip-update.py does not support the --force flag:

user@router:/etc/cron.hourly$ cat /tmp/geoip-update.log
usage: geoip-update.py [-h] [--init]
geoip-update.py: error: unrecognized arguments: --force

I would assume there is also a "update geoip on reboot" somewhere in the system, it potentially suffers from the same issue?

Details

Version
1.5.0
Is it a breaking change?
Behavior change
Issue type
Bug (incorrect behavior)