Some Radius Servers do not support Radius Accounting, or it is disabled.
In this case, radius authentication of SSH sessions lasts a long time.
Example:
Config:
set system login radius server 192.168.139.100 key 'gns3' set system login radius server 192.168.139.100 priority '100' set system login radius server 192.168.139.101 key 'gns3' set system login radius server 192.168.139.101 priority '90'
Logs:
vyos@vyos:~$ Apr 3 10:07:55 vyos sshd[14368]: Accepted password for test1 from 192.168.139.1 port 27312 ssh2
Apr 3 10:07:57 vyos sshd[14368]: pam_radius_auth(sshd:session): server 192.168.139.100:1812 failed to respond Apr 3 10:07:59 vyos sshd[14368]: pam_radius_auth(sshd:session): server 192.168.139.101:1812 failed to respond Apr 3 10:07:59 vyos sshd[14368]: pam_radius_auth(sshd:session): All RADIUS servers failed to respond Apr 3 10:07:59 vyos sshd[14368]: pam_unix(sshd:session): session opened for user test1(uid=1001) by (uid=0) Apr 3 10:07:59 vyos systemd[1]: Created slice User Slice of UID 1001. Apr 3 10:07:59 vyos systemd[1]: Starting User Runtime Directory /run/user/1001... Apr 3 10:07:59 vyos systemd-logind[1134]: New session 34 of user test1. Apr 3 10:07:59 vyos systemd[1]: Finished User Runtime Directory /run/user/1001. Apr 3 10:07:59 vyos systemd[1]: Starting User Manager for UID 1001... Apr 3 10:08:01 vyos (systemd): pam_radius_auth(systemd-user:session): server 192.168.139.100:1812 failed to respond Apr 3 10:08:03 vyos (systemd): pam_radius_auth(systemd-user:session): server 192.168.139.101:1812 failed to respond Apr 3 10:08:03 vyos (systemd): pam_radius_auth(systemd-user:session): All RADIUS servers failed to respond Apr 3 10:08:03 vyos (systemd): pam_unix(systemd-user:session): session opened for user test1(uid=1001) by (uid=0) Apr 3 10:08:03 vyos systemd[14371]: Queued start job for default target default.target. Apr 3 10:08:03 vyos systemd[14371]: Reached target paths.target - Paths. Apr 3 10:08:03 vyos systemd[14371]: Reached target sockets.target - Sockets. Apr 3 10:08:03 vyos systemd[14371]: Reached target timers.target - Timers. Apr 3 10:08:03 vyos systemd[14371]: Reached target basic.target - Basic System. Apr 3 10:08:03 vyos systemd[14371]: Reached target default.target - Main User Target. Apr 3 10:08:03 vyos systemd[14371]: Startup finished in 90ms. Apr 3 10:08:03 vyos systemd[1]: Started User Manager for UID 1001. Apr 3 10:08:03 vyos systemd[1]: Started Session 34 of User test1. Apr 3 10:08:03 vyos systemd[1]: opt-vyatta-config-tmp-new_config_14394.mount: Deactivated successfully. Apr 3 10:08:03 vyos sshd[14368]: pam_env(sshd:session): deprecated reading of user environment enabled
As we see, a successful connection takes 8 sec. And it is without a configured Radius timeout. But if there are more than 2 servers, and the timeout is greater than the default, it can take a minute or more.