Page MenuHomeVyOS Platform

Route-map and summary-only do not work in BGP aggregation at the same time
Closed, ResolvedPublicBUG

Description

Route-map and summary-only do not work in BGP aggregation at the same time
Example:
VyOS Configuration:

set interfaces ethernet eth1 address '192.168.0.1/30'
set interfaces ethernet eth2 address '192.168.0.5/30'
set policy route-map TEST-MAP rule 10 action 'permit'
set policy route-map TEST-MAP rule 10 set local-preference '200'
set protocols bgp address-family ipv4-unicast aggregate-address 192.168.0.0/24 route-map 'TEST-MAP'
set protocols bgp address-family ipv4-unicast aggregate-address 192.168.0.0/24 summary-only
set protocols bgp address-family ipv4-unicast redistribute connected
set protocols bgp system-as '65000'

Applying config in FRR

vyos# show run
Building configuration...

Current configuration:
!
frr version 9.1
frr defaults traditional
hostname vyos
log syslog
log facility local7
service integrated-vtysh-config
!
router bgp 65000
 no bgp ebgp-requires-policy
 no bgp default ipv4-unicast
 no bgp network import-check
 !
 address-family ipv4 unicast
  aggregate-address 192.168.0.0/24 summary-only
  redistribute connected
 exit-address-family
exit
!
ip prefix-list TEST-PREFIX seq 10 permit 192.168.0.0/24
!
route-map TEST-MAP permit 10
 set local-preference 200
exit
!
rpki
exit
!
end

After adding router-id

vyos@vyos# set protocols bgp parameters router-id 1.1.1.1

FRR configuration part

router bgp 65000
 bgp router-id 1.1.1.1
 no bgp ebgp-requires-policy
 no bgp default ipv4-unicast
 no bgp network import-check
 !
 address-family ipv4 unicast
  aggregate-address 192.168.0.0/24 route-map TEST-MAP
  redistribute connected
 exit-address-family
exit

Should be:

router bgp 65000
 bgp router-id 1.1.1.1
 no bgp ebgp-requires-policy
 no bgp default ipv4-unicast
 no bgp network import-check
 !
 address-family ipv4 unicast
  aggregate-address 192.168.0.0/24 summary-only route-map TEST-MAP
  redistribute connected
 exit-address-family
exit

Details

Difficulty level
Unknown (require assessment)
Version
VyOS 1.5-rolling-202404010021, VyOS 1.4.0-epa2, VyOS 1.3.6
Why the issue appeared?
Will be filled on close
Is it a breaking change?
Perfectly compatible
Issue type
Bug (incorrect behavior)

Event Timeline

a.apostoliuk changed the task status from Open to In progress.Mon, Apr 1, 3:59 PM
a.apostoliuk claimed this task.
a.apostoliuk triaged this task as Normal priority.
a.apostoliuk created this task.
c-po moved this task from Need Triage to Finished on the VyOS 1.5 Circinus board.
c-po moved this task from Need Triage to Finished on the VyOS 1.4 Sagitta (1.4.0-epa3) board.