Page MenuHomeVyOS Platform

Not all AFIs are compatible with VRF
Closed, ResolvedPublicBUG

Description

Only Unicast/Multicast/EVPN SAFIs supported in non-core instances.

to reproduce

set interfaces bridge br0 address '10.1.1.2/30'
set interfaces bridge br0 member interface veth0

set interfaces virtual-ethernet veth0 peer-name 'veth10'
set interfaces virtual-ethernet veth10 address '10.1.1.1/30'
set interfaces virtual-ethernet veth10 peer-name 'veth0'
set interfaces virtual-ethernet veth10 vrf 'bgp'

set protocols bgp system-as '65001'
set vrf name bgp protocols bgp neighbor 10.1.1.2 address-family ipv4-unicast
set vrf name bgp protocols bgp neighbor 10.1.1.2 port '1790'
set vrf name bgp protocols bgp neighbor 10.1.1.2 remote-as '65001'
set vrf name bgp protocols bgp system-as '65001'
set vrf name bgp table '1010'

commit

set vrf name bgp protocols bgp neighbor 10.1.1.2 address-family ipv4-flowspec
commit

Traceback:

Traceback (most recent call last):
  File "/usr/libexec/vyos/conf_mode/protocols_bgp.py", line 594, in <module>
    apply(c)
  File "/usr/libexec/vyos/conf_mode/protocols_bgp.py", line 585, in apply
    frr_cfg.commit_configuration(bgp_daemon)
  File "/usr/lib/python3/dist-packages/vyos/frr.py", line 482, in commit_configuration
    raise ConfigurationNotValid(f'Config commit retry counter ({count_max}) exceeded for {daemon} dameon!')
vyos.frr.ConfigurationNotValid: Config commit retry counter (5) exceeded for bgpd dameon!

vtsyh:

cont t
  router bgp 65001 vrf bgp
  address-family ipv4 flowspec



r4# conf t
r4(config)# router bgp 65001 vrf bgp
r4(config-router)#  address-family ipv4 flowspec 
  <cr>  
r4(config-router)#  address-family ipv4 flowspec 
Only Unicast/Multicast/EVPN SAFIs supported in non-core instances.
r4(config-router)#

Details

Version
VyOS 1.5-rolling-202312101002
Is it a breaking change?
Perfectly compatible
Issue type
Bug (incorrect behavior)

Event Timeline

Viacheslav renamed this task from BGP Impossible to use address family flowspec with VRF to BGP address family flowspec incompatible with VRF.Apr 24 2024, 7:32 AM
Viacheslav changed the task status from Open to In progress.
Viacheslav claimed this task.
Viacheslav renamed this task from BGP address family flowspec incompatible with VRF to Not all AFIs compatible with VRF.Apr 24 2024, 10:58 AM
Viacheslav moved this task from Open to Finished on the VyOS 1.5 Circinus board.
Viacheslav moved this task from Need Triage to Finished on the VyOS 1.4 Sagitta (1.4.0-epa3) board.
dmbaturin renamed this task from Not all AFIs compatible with VRF to Not all AFIs are compatible with VRF.May 11 2024, 7:12 PM
dmbaturin removed a project: VyOS 1.5 Circinus.
dmbaturin changed Is it a breaking change? from Unspecified (possibly destroys the router) to Perfectly compatible.